全部文档

( 最近更新时间:2020-04-28 19:00:00 )

`

# 环境要求

名称 版本
Xcode 11 +
手机系统 8.0 +

# 导入 SDK

SDK 支持使用 CocoaPods 导入并管理 SDK。 需安装 CocoaPods 环境,请参照 CocoaPods 安装 (opens new window)

# 导入
  1. cd 至项目根目录

  2. 执行 pod init

  3. 执行 open -e Podfile

  4. Podfile 文件中添加下面内容

    pod 'RongCloudIM/IMKit', '~> 4.0.3.3'
    pod 'RongCloudIM/IMLib', '~> 4.0.3.3'
    
    已复制
    1
    2

    如需指定具体版本,请注意 pod 使用规范 (opens new window)。 请点击 下载页 (opens new window) 获知最新版本。

  5. 执行 pod install

  6. 双击打开 .xcworkspace

# 升级
  1. 执行 pod repo update

  2. 执行 pod search RongCloudIM 查询最新版本

  3. 替换 Podfile 文件内容

  4. 执行 pod install

# 查看当前导入版本
  1. 打开根目录
  2. Pods/RongCloudIM/RongCloudIM/RongIMLib.framework 目录下
  3. 打开 info.plist 文件
  4. 找到 Bundle versions string, short 字段,其 value 值为当前集成版本号
# 清除 Pod 缓存
  1. 移除项目目录 Pods 文件下的 RongCloudIM
  2. 删除 CocoaPods 目录缓存, 找到 ~/Library/Caches/CocoaPods/Pods/Release, 删除此目录。
  3. 点击 Xcode -> Preferences -> Locations -> Derived Data 点击下方的右箭头跳转到相应目, 删除此目录即可。
  4. 项目根目录执行 pod repo update
  5. 项目根目录执行 pod install

# 常见问题

Q1: 集成 SDK 必须使用 Xcode 11 吗?
A1: 融云 SDK 2.9.25 及之后的版本兼容了 iOS 13 ,需要兼容 iOS 13,则需使用新版本的 Xcode;不需要兼容 iOS 13 或者不想升级到 Xcode 11,请使用 2.9.24 版本的 SDK。 不兼容的原因 (opens new window)

文档是否解决您的问题 ?

如果遇到产品相关问题,您可 提交工单 寻求帮助